SmallNetBuilder Forums
Go Back   SmallNetBuilder Forums > Wireless Networking > ASUS Wireless > Asuswrt-Merlin

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 02-04-2013, 01:11 PM
mmmmmm mmmmmm is offline
Member
 
Join Date: Nov 2012
Posts: 35
Thanks: 24
Thanked 3 Times in 2 Posts
mmmmmm is just starting out
Default ipkg: can't resolve symbol '__ctype_b_loc'

Hi,

after installing the following components (on my attempt to install gallery):
- lighttpd
- mysql
- php (with serveral extensions: ctype, mbstring, xml, json, iconv, filter ...)

it seems they broke my environment.

When running ipkg list I get the error:
Code:
admin@RT-N66U:/tmp/mnt/sda1# ipkg update
ipkg: can't resolve symbol '__ctype_b_loc'
When trying to run transmission daemon I get:
Code:
admin@RT-N66U:/tmp/mnt/sda1# /opt/etc/init.d/S95transmission start
Starting transmission-daemon:.[20:11:09.694] Couldn't read "/opt/etc/transmission-daemon/settings.json": Not a regular file
[FAILED]
Can anyone please give some pointers on what went wrong and how to fix these.

I actually managed to get the lighttpd and php running. Also the mySql was ok.

Thank you

Last edited by mmmmmm; 02-04-2013 at 01:15 PM.
Reply With Quote
  #2  
Old 02-05-2013, 03:20 AM
mmmmmm mmmmmm is offline
Member
 
Join Date: Nov 2012
Posts: 35
Thanks: 24
Thanked 3 Times in 2 Posts
mmmmmm is just starting out
Default

I realize that this is Linux related (not Asus, RT-N66U or Merlin's version), but can anyone please provide some assistance?

Is it possible that a firmware rewrite/upgrade will solve this?
Reply With Quote
  #3  
Old 02-06-2013, 10:25 PM
RMerlin's Avatar
RMerlin RMerlin is offline
Very Senior Member
 
Join Date: Apr 2012
Location: Canada
Posts: 10,483
Thanks: 54
Thanked 5,891 Times in 2,393 Posts
RMerlin is just starting out
Default

The problem seem to be with your Optware/Entware repo. I'm not really an expert at fixing package conflicts, best I could suggest is to rename your current asusware directory (or whatever directory contains your Entware filesystem), reboot, and restart from scratch. You can copy back any customized file from the backup you made before rebooting.
__________________
Asuswrt-Merlin: Customized firmware for Asus routers
Github: github.com/RMerl - Twitter: RMerlinDev
See the sticky post for more info.
Reply With Quote
The Following User Says Thank You to RMerlin For This Useful Post:
  #4  
Old 02-07-2013, 01:19 AM
mmmmmm mmmmmm is offline
Member
 
Join Date: Nov 2012
Posts: 35
Thanks: 24
Thanked 3 Times in 2 Posts
mmmmmm is just starting out
Default

Quote:
Originally Posted by RMerlin View Post
The problem seem to be with your Optware/Entware repo.
You are absolutely right.
I realized that I combined packages from optware & entware.
I simply removed the asusware directory and reinstalled everything from scratch, but this time only entware packages. Now everything is ok.

Thank you very much, RMerlin!
Reply With Quote
  #5  
Old 02-07-2013, 01:22 AM
mmmmmm mmmmmm is offline
Member
 
Join Date: Nov 2012
Posts: 35
Thanks: 24
Thanked 3 Times in 2 Posts
mmmmmm is just starting out
Default

Quote:
Originally Posted by mmmmmm View Post
I realize that this is Linux related (not Asus, RT-N66U or Merlin's version), but can anyone please provide some assistance?

Is it possible that a firmware rewrite/upgrade will solve this?
To whom it might interest:
The firmware upgrade did not solve the issue (I lost jffs contents in the upggrade process )

The problem was, as Merlin stated, mixing Optware/Entware repositories.
The solution was a clean reinstall only from Entware.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 12:22 AM.


Top 10 Stats
Top Posters* Top Thanked
RMerlin  362
L&LD  168
azazel1024  156
stevech  133
ChristineBCW  117
john9527  115
hggomes  84
dirtyclyde  65
TonyH  64
4Leaf  52
RMerlin  5890
stevech  344
john9527  303
ryzhov_al  274
TeHashX  230
L&LD  225
RogerSC  195
sinshiva  146
joegreat  126
sfx2000  124
Most Viewed Threads* Hottest Threads*
Old Asuswrt-Merli...  35688
Old Shellshock...  23671
Old Asuswrt-Merli...  19809
Old Does...  12245
Old T-Mobile...  9893
Old Most stable...  7162
Old RT-AC87R (U)...  6181
Old RT-N66U...  6133
Old Can't trust...  4023
Old New...  3106
Old Asuswrt-Merli...  171
Old Asuswrt-Merli...  89
Old Does...  72
Old Antenna...  62
Old T-Mobile...  61
Old RT-AC87R (U)...  42
Old Most stable...  37
Old Simple NAS...  37
Old USB N...  37
Old Shellshock...  31


Powered by vBulletin® Version 3.7.3
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
© 2006-2014 Pudai LLC All Rights Reserved.