SmallNetBuilder Forums
Go Back   SmallNetBuilder Forums > Wireless Networking > ASUS Wireless > Asuswrt-Merlin

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 01-17-2013, 09:17 PM
rlcronin rlcronin is offline
Member
 
Join Date: Sep 2010
Posts: 88
Thanks: 5
Thanked 2 Times in 2 Posts
rlcronin is just starting out
Default Use custom DNS and not my ISP's DNS

I want to always use OpenDNS. I've configured the primary OpenDNS server on my DHCP client configuration page. My clients report that they're using that server and 192.168.1.1 as their DNS servers. The router does have my ISP's two DNS servers listed on the Internet Status page. I have observed that my clients are only using the OpenDNS server *sometimes* (by going to welcome.opendns.com and 1 minute being told that I am using OpenDNS and then going there again a few minutes later and being told I am *not* using OpenDNS).

I presume this is because the client has both the OpenDNS server address and the router address as DNS servers (i.e. when the query goes to the router's address, the router is sending it off to my ISP and when that response comes back first, it gets used in preference to the one from OpenDNS?).

I just want to always use OpenDNS and never my ISP's DNS. How can I make that happen? Is there a way to configure DNS IP addresses in the router that will always be used instead of the ones it gets from my ISP?
--
bc
Reply With Quote
  #2  
Old 01-18-2013, 06:22 AM
r.rebergen r.rebergen is offline
New Member
 
Join Date: Jan 2013
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
r.rebergen is just starting out
Default

I assume your setup is incorrect. You need to configure the OpenDNS DNS servers on the WAN page. Every client within the network then needs to connect to your router's IP for DNS requests. I think the mixup is caused by your ISP's DNS adresses.
In my case this is set up as described and works flawless!

Last edited by r.rebergen; 01-18-2013 at 06:25 AM.
Reply With Quote
  #3  
Old 01-18-2013, 11:08 AM
rlcronin rlcronin is offline
Member
 
Join Date: Sep 2010
Posts: 88
Thanks: 5
Thanked 2 Times in 2 Posts
rlcronin is just starting out
Default

Quote:
Originally Posted by r.rebergen View Post
I assume your setup is incorrect. You need to configure the OpenDNS DNS servers on the WAN page. Every client within the network then needs to connect to your router's IP for DNS requests. I think the mixup is caused by your ISP's DNS adresses.
In my case this is set up as described and works flawless!
D'oh! Ok, this was caused by me not understanding the meaning of the "Connect to DNS server automatically" option on the WAN page. I had noticed there was no place to manually specify DNS servers on that page. It just never dawned on me that I had to uncheck that option to get the server fields to appear. Thanks for the nudge ...
--
bc
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 12:15 PM.


Top 10 Stats
Top Posters* Top Thanked
RMerlin  368
L&LD  169
azazel1024  152
stevech  130
john9527  121
ChristineBCW  116
hggomes  84
dirtyclyde  65
TonyH  63
4Leaf  52
RMerlin  5890
stevech  344
john9527  303
ryzhov_al  274
TeHashX  230
L&LD  223
RogerSC  195
sinshiva  146
joegreat  126
sfx2000  124
Most Viewed Threads* Hottest Threads*
Old Asuswrt-Merli...  34328
Old Shellshock...  23375
Old Asuswrt-Merli...  19699
Old Does...  11694
Old T-Mobile...  9586
Old Most stable...  7104
Old RT-AC87R (U)...  6096
Old RT-N66U...  6019
Old Can't trust...  3960
Old New...  3040
Old Asuswrt-Merli...  171
Old Asuswrt-Merli...  89
Old Does...  70
Old Antenna...  62
Old T-Mobile...  58
Old RT-AC87R (U)...  42
Old USB N...  37
Old Most stable...  37
Old Simple NAS...  36
Old Shellshock...  31


Powered by vBulletin® Version 3.7.3
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
© 2006-2014 Pudai LLC All Rights Reserved.