SmallNetBuilder Forums
Go Back   SmallNetBuilder Forums > Wireless Networking > ASUS Wireless > Asuswrt-Merlin

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 02-25-2013, 12:25 PM
professordave professordave is offline
New Member
 
Join Date: Jan 2013
Posts: 29
Thanks: 0
Thanked 0 Times in 0 Posts
professordave is just starting out
Default Wifi Connection Lost: And Solution

Problem: After a few hours, one of two wireless devices are unable to reconnect to wifi network, to temporarily fix, either a power cycle of the device or the router is needed, then the device is able to reconnect to the network.

The devices that are having problems are wireless audio streamers, Logitech Squeezebox Radios, I have two. Usually, one of them loses wifi connection, not both, and it seems random which one loses the wireless connection.

Router: ASUS RT-AC66U, merlin 3.0.0.4.270.24

Background: Have other wireless devices in the house that NEVER lose connections, tivo, wireless scale, Squeezebox Touch (a different model then the squeezebox radios listed above, only have 1 of this one) all retain wireless connection over time and do not need to be power cycled to work

I try and leave all devices using regular DHCP if possible, the less I have to tweak the network the better. I have setup 2 static DHCP reservations for a Synology NAS and an imac.


Settings that seem to fix the problem:

1) Giving them each a unique host name in their /etc/hostname file, the squeezebox radios are tiny linux boxes:
*)enable ssh on each radio, then went into both radios and set the name in the /etc/hostname file
*) RedSqueezeboxRadio
*) BlackSqueezeboxRadio

This seems to have fixed the problem, it has only been a day, so we will see.


2) Turn off automatic channel selection, picked a channel at random, in this case channel 9.
This also seemed to fix the problem. But only left this setting enabled for a day, so do not know for sure that this setting fixed the problem.

What did NOT work:
I set up a static DHCP reservation in the router for 1 of the radios. Within a few hours, both were unable to reconnect to the network.
Reply With Quote
  #2  
Old 02-25-2013, 01:07 PM
joegreat's Avatar
joegreat joegreat is offline
Very Senior Member
 
Join Date: Jan 2013
Location: Vienna, Austria
Posts: 402
Thanks: 502
Thanked 104 Times in 84 Posts
joegreat is just starting out
Red face

Quote:
Originally Posted by professordave View Post
Problem: After a few hours, one of two wireless devices are unable to reconnect to wifi network, to temporarily fix, either a power cycle of the device or the router is needed, then the device is able to reconnect to the network.

2) Turn off automatic channel selection, picked a channel at random, in this case channel 9.
This also seemed to fix the problem. But only left this setting enabled for a day, so do not know for sure that this setting fixed the problem.
Hi,

What comes to my mind when I read thru your problem and solution description is:
Can it be that you have many / heavy other WLANs in your neighborhood?

Can you scan WLANs with inSSIDer on your Notebook/PC or via a Android device with Wifi Analyzer.
There you can see which channel is free and this one you should use as fixed channel on the router. Also you should set 20 MHz only bandwidth.
If you are not able to find a single free channel (remember that you need +/- 1 channel free on left and right), you should enable also the Enhanced Interference Management on the 'Professional' page.

Maybe this would give you a more stable WLAN connection for you streaming clients.

By the way: Did you check the reception levels of the two devices?
You can see them on the 'System Log' on the third tab 'Wireless Log'. The rssi level should be higher (means lower '- value') then the noise level of the WLAN router (by approx. 10 dBm at least).

With kind regards
Joe
__________________
Asus RT-AC68U running Optware for Transmission & other tools + Asus RT-N66U in AP-Mode for WLAN extension = Firmware: 374.40_beta3 & 374.40_0 (Merlin build)

Last edited by joegreat; 02-25-2013 at 05:45 PM.
Reply With Quote
  #3  
Old 02-25-2013, 04:14 PM
professordave professordave is offline
New Member
 
Join Date: Jan 2013
Posts: 29
Thanks: 0
Thanked 0 Times in 0 Posts
professordave is just starting out
Default

Okay, here are the stats, the two devices that are giving me trouble are the red and black squeezeboxes.

I am able to stream with other clients, for example, I have a roku 2xs and am able to stream videos and it never loses the wifi connection.

I have the stats listed twice, once before I hit the refresh, with some ?? listed, and then again after I hit the refresh button.



SSID: *****
RSSI: 0 dBm SNR: 0 dB noise: -63 dBm Channel: 11u
BSSID: 30:85:A9:E8:E9:58 Capability: ESS ShortSlot




Mode : AP Only

Stations List Rx/Tx speed rssi state
--------------------------------------------------------------------------------------
00:04:20:28:02:49 192.168.1.146 BlackSqueezebox 1/48 Mbps 9 dBm assoc auth
F0:CB:A1:0B:9E:44 192.168.1.105 * ??/65 Mbps 50 dBm assoc auth
00:04:20:23:8D:96 192.168.1.69 SqueezeboxTouch 2/54 Mbps 9 dBm assoc auth
00:04:20:2C:82:92 192.168.1.195 RedSqueezeboxRa 1/48 Mbps ?? dBm assoc auth
00:24:81:BA:9D:43 TIVO-6580101806 36/1 Mbps ?? dBm assoc auth
B8:3E:59:00:4C:D5 192.168.1.213 NP-13G2DX004548 ??/65 Mbps -30 dBm assoc auth
00:12:0E:6F:B7:08 192.168.1.79 * 1/11 Mbps ?? dBm assoc auth

SSID: *****
RSSI: 0 dBm SNR: 0 dB noise: -84 dBm Channel: 36/80
BSSID: 30:85:A9:E8:E9:5C Capability: ESS

Mode : AP Only

Stations List Rx/Tx speed rssi state
--------------------------------------------------------------------------------------
D8:A2:5E:47:CE:C5 192.168.1.102 * 26/65 Mbps ?? dBm assoc auth
00:1F:5B:C9:3D:D1 192.168.1.192 270/81 Mbps ?? dBm assoc auth
00:11:D9:25:30:F2 192.168.1.145 * 300/270 Mbps ?? dBm assoc auth



====
SSID:****
RSSI: 0 dBm SNR: 0 dB noise: -62 dBm Channel: 11u
BSSID: 30:85:A9:E8:E9:58 Capability: ESS ShortSlot

Mode : AP Only

Stations List Rx/Tx speed rssi state
--------------------------------------------------------------------------------------
00:04:20:28:02:49 192.168.1.146 BlackSqueezebox 12/36 Mbps -35 dBm assoc auth
F0:CB:A1:0B:9E:44 192.168.1.105 * 65/1 Mbps -55 dBm assoc auth
00:04:20:23:8D:96 192.168.1.69 SqueezeboxTouch 2/11 Mbps -28 dBm assoc auth
00:04:20:2C:82:92 192.168.1.195 RedSqueezeboxRa 18/36 Mbps -30 dBm assoc auth
00:24:81:BA:9D:43 TIVO-6580101806 24/1 Mbps 1 dBm assoc auth
B8:3E:59:00:4C:D5 192.168.1.213 NP-13G2DX004548 65/65 Mbps -29 dBm assoc auth
00:12:0E:6F:B7:08 192.168.1.79 * 9/1 Mbps -45 dBm assoc auth

SSID: *****
RSSI: 0 dBm SNR: 0 dB noise: -84 dBm Channel: 36/80
BSSID: 30:85:A9:E8:E9:5C Capability: ESS

Mode : AP Only

Stations List Rx/Tx speed rssi state
--------------------------------------------------------------------------------------
D8:A2:5E:47:CE:C5 192.168.1.102 * 26/6 Mbps -63 dBm assoc auth
00:1F:5B:C9:3D:D1 192.168.1.192 270/54 Mbps -57 dBm assoc auth
00:11:D9:25:30:F2 192.168.1.145 * 300/270 Mbps -54 dBm assoc auth
Reply With Quote
  #4  
Old 02-25-2013, 04:21 PM
joegreat's Avatar
joegreat joegreat is offline
Very Senior Member
 
Join Date: Jan 2013
Location: Vienna, Austria
Posts: 402
Thanks: 502
Thanked 104 Times in 84 Posts
joegreat is just starting out
Default

Hi,

Yep, your client signals are all in a good signal level/range.

What about the free channel theory for the 2.4G WLAN network?

With kind regards
Joe
__________________
Asus RT-AC68U running Optware for Transmission & other tools + Asus RT-N66U in AP-Mode for WLAN extension = Firmware: 374.40_beta3 & 374.40_0 (Merlin build)
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 12:21 AM.

Top 10 Stats
Top Posters* Top Thanked
RMerlin  311
L&LD  162
thelonelycode...  142
stevech  140
azazel1024  103
KGB7  64
Adamm  60
TeHashX  59
jim769  56
speedingcheet...  55
RMerlin  4368
stevech  270
ryzhov_al  199
TeHashX  191
RogerSC  164
L&LD  163
joegreat  104
jlake  98
PrivateJoker  93
sinshiva  85
Most Viewed Threads* Hottest Threads*
Old Beta Version...  16968
Old ASUS...  15941
Old Asuswrt-Merli...  14644
Old 'Heartbleed'...  12117
Old Potential...  7501
Old Groundhog...  5925
Old Asus-Merlin...  5766
Old Linksys...  4452
Old Linksys...  4123
Old [TUTORIAL]...  2643
Old Asuswrt-Merli...  140
Old Beta Version...  112
Old Linksys...  100
Old Potential...  98
Old ASUS...  92
Old Groundhog...  49
Old Asus router...  43
Old [TUTORIAL]...  39
Old Asus-Merlin...  35
Old 'Heartbleed'...  33



Powered by vBulletin® Version 3.7.3
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
© 2006-2014 Pudai LLC All Rights Reserved.