SmallNetBuilder Forums
Go Back   SmallNetBuilder Forums > Wireless Networking > ASUS Wireless > Asuswrt-Merlin

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 11-20-2012, 09:57 AM
MrBackslash MrBackslash is offline
New Member
 
Join Date: Nov 2012
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
MrBackslash is just starting out
Confused WOL issue

Hello, i have problems using WOL on my RT-N66U (3.0.0.4.246.20). WOL is only working for some hours but then suddenly stopps working (it is not possible to wake up a pc anymore). After rebooting the router WOL is working again. Any suggestions?
Reply With Quote
  #2  
Old 11-20-2012, 10:03 AM
RMerlin's Avatar
RMerlin RMerlin is online now
Very Senior Member
 
Join Date: Apr 2012
Location: Canada
Posts: 8,613
Thanks: 44
Thanked 4,497 Times in 1,908 Posts
RMerlin is just starting out
Default

This is usually caused by a power management setting on your PC. Check both in your BIOS and the network interface settings in Windows' Device Manager.

Are you connecting that PC directly to the router, or to a switch? If it's a switch, it could also be caused by a power management feature of the switch that turns off the port after a while if there's no activity.
__________________
Asuswrt-Merlin: Customized firmware for Asus routers
Github: github.com/RMerl - Twitter: RMerlinDev
See the sticky post for more info.
Reply With Quote
  #3  
Old 11-20-2012, 10:20 AM
MrBackslash MrBackslash is offline
New Member
 
Join Date: Nov 2012
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
MrBackslash is just starting out
Default

My PC and also the NAS are directly connected to the router. With a different router everything is working fine. Both have static IP's. Is it possible that the N66U is loosing this IP's?
Reply With Quote
  #4  
Old 11-20-2012, 12:29 PM
RMerlin's Avatar
RMerlin RMerlin is online now
Very Senior Member
 
Join Date: Apr 2012
Location: Canada
Posts: 8,613
Thanks: 44
Thanked 4,497 Times in 1,908 Posts
RMerlin is just starting out
Default

Quote:
Originally Posted by MrBackslash View Post
My PC and also the NAS are directly connected to the router. With a different router everything is working fine. Both have static IP's. Is it possible that the N66U is loosing this IP's?
The target's IP is irrelevant in a WOL usage scenario. You want to send the packet to the broadcast address, not the device's IP, because there is no way to know what IP a given device was using before going to sleep - that IP might very well have been reallocated since it was last seen.

Some devices are more picky however as to the type of packets they will handle. Some devices work better with the wol tool (which I use on the WOL page), others with the ether-wake tool (which Asus uses on the AiCloud page).

Try going to the Tools -> Run Cmd page and manually using ether-wake to see if it works better for you:

Quote:
/usr/bin/ether-wake -i br0 -b xx:xx:xx:xx:xx;
(replacing the xx section with the target MAC)
__________________
Asuswrt-Merlin: Customized firmware for Asus routers
Github: github.com/RMerl - Twitter: RMerlinDev
See the sticky post for more info.
Reply With Quote
  #5  
Old 11-20-2012, 01:54 PM
MrBackslash MrBackslash is offline
New Member
 
Join Date: Nov 2012
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
MrBackslash is just starting out
Default

I've logged my WOL requests:

First try WOL over web (not working):
Nov 20 19:39:50 kernel: ACCEPT <4>ACCEPT IN=eth0 OUT=br0 <1>SRC=2.206.0.63 DST=192.168.1.100 <1>LEN=130 TOS=0x00 PREC=0x00 TTL=47 ID=0 DF PROTO=UDP <1>SPT=39930 DPT=9 LEN=110
Nov 20 19:39:59 kernel: ACCEPT <4>ACCEPT IN=eth0 OUT= MAC=ff:ff:ff:ff:ff:ff:00:22:90:c7:22:d9:08:00 <1>SRC=10.158.128.1 DST=255.255.255.255 <1>LEN=309 TOS=0x00 PREC=0x00 TTL=255 ID=59788 PROTO=UDP <1>SPT=67 DPT=68 LEN=289


Second over Router WOL Page (working):
Nov 20 19:45:43 kernel: ACCEPT <4>ACCEPT IN=eth0 OUT= MAC=ff:ff:ff:ff:ff:ff:00:22:90:c7:22:d9:08:00 <1>SRC=10.158.128.1 DST=255.255.255.255 <1>LEN=309 TOS=0x00 PREC=0x00 TTL=255 ID=26795 PROTO=UDP <1>SPT=67 DPT=68 LEN=289
Nov 20 19:45:45 dnsmasq-dhcp[491]: DHCPDISCOVER(br0) 00:11:32:16:70:3f
Nov 20 19:45:45 dnsmasq-dhcp[491]: DHCPOFFER(br0) 192.168.1.100 00:11:32:16:70:3f
Nov 20 19:45:45 dnsmasq-dhcp[491]: DHCPDISCOVER(br0) 00:11:32:16:70:3f
Nov 20 19:45:45 dnsmasq-dhcp[491]: DHCPOFFER(br0) 192.168.1.100 00:11:32:16:70:3f
Nov 20 19:45:45 dnsmasq-dhcp[491]: DHCPREQUEST(br0) 192.168.1.100 00:11:32:16:70:3f
Nov 20 19:45:45 dnsmasq-dhcp[491]: DHCPACK(br0) 192.168.1.100 00:11:32:16:70:3f DiskStation


Any suggestions whats going wrong?
Reply With Quote
Reply

Tags
wol

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 02:12 AM.

Top 10 Stats
Top Posters* Top Thanked
RMerlin  412
stevech  153
thelonelycode...  147
L&LD  126
azazel1024  115
KGB7  99
jim769  82
DrTeeth  71
Adamm  64
speedingcheet...  61
RMerlin  4497
stevech  276
ryzhov_al  199
TeHashX  194
RogerSC  166
L&LD  163
joegreat  105
jlake  102
PrivateJoker  93
sinshiva  89
Most Viewed Threads* Hottest Threads*
Old Asuswrt-Merli...  32494
Old Asuswrt-Merli...  27313
Old ASUS...  23121
Old Beta Version...  17592
Old 'Heartbleed'...  14446
Old Linksys...  9815
Old Potential...  7995
Old Asus-Merlin...  7219
Old Groundhog...  6469
Old Linksys...  6192
Old Asuswrt-Merli...  220
Old Asuswrt-Merli...  196
Old Linksys...  149
Old ASUS...  126
Old Beta Version...  112
Old Potential...  98
Old Linksys...  83
Old Groundhog...  49
Old Asus router...  43
Old USB drive...  40



Powered by vBulletin® Version 3.7.3
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
© 2006-2014 Pudai LLC All Rights Reserved.