SmallNetBuilder Forums
Go Back   SmallNetBuilder Forums > NAS > General NAS Discussion

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 02-26-2013, 07:02 AM
dotdavid dotdavid is offline
New Member
 
Join Date: Feb 2013
Posts: 5
Thanks: 2
Thanked 0 Times in 0 Posts
dotdavid is just starting out
Unhappy Zyxel NSA-221 RAID1 Degraded

I have had a NSA-221 for a while now running 2x 250GB drives in a RAID1 array with no problems on firmware 4.40. I recently upgraded to a pair of 3TB Seagate ST3000DM001 drives and for a few days after installation things were fine. However after those few days the NAS became unresponsive (couldn't log into web UI or access SMB shares) so I rebooted it. After the reboot the RAID array was reported as being degraded. Both disks are reported as "healthy" in the SMART software add-on however.

I attempted to repair the RAID array but it gave me an error saying something along the lines of the second hard drive must be equal or greater in size to the first hard drive. I tried the "failed" drive in a Ubuntu VM and the data appeared to be there, so I wiped all the partitions, rebuilt the RAID volume and restored from a backup.

However three or four days after doing this the RAID array failed again, with the same symptoms.

My question is; is this symptomatic of a hard drive failure (considering the healthy SMART status and fact I can read the drive's data in Ubuntu) or is it just buggy RAID software in the NAS? I would ordinarily blame the drive, but the NAS *is* extraordinarily buggy so I don't really trust it not to waste my time.

Are there any good tools that would diagnose a drive failure - I was thinking of using Seagate's SeaTools with the drive in a USB disk caddy but wonder if it would get confused with the filesystem on the drive considering it's for Windows/DOS only.

Any advice gratefully received...
Reply With Quote
  #2  
Old 02-26-2013, 03:05 PM
tipstir tipstir is offline
Very Senior Member
 
Join Date: Aug 2008
Location: South Florida
Posts: 1,632
Thanks: 0
Thanked 35 Times in 35 Posts
tipstir is just starting out
Send a message via AIM to tipstir Send a message via Yahoo to tipstir Send a message via Skype™ to tipstir
Default

Quote:
Originally Posted by dotdavid View Post
I have had a NSA-221 for a while now running 2x 250GB drives in a RAID1 array with no problems on firmware 4.40. I recently upgraded to a pair of 3TB Seagate ST3000DM001 drives and for a few days after installation things were fine. However after those few days the NAS became unresponsive (couldn't log into web UI or access SMB shares) so I rebooted it. After the reboot the RAID array was reported as being degraded. Both disks are reported as "healthy" in the SMART software add-on however.

I attempted to repair the RAID array but it gave me an error saying something along the lines of the second hard drive must be equal or greater in size to the first hard drive. I tried the "failed" drive in a Ubuntu VM and the data appeared to be there, so I wiped all the partitions, rebuilt the RAID volume and restored from a backup.

However three or four days after doing this the RAID array failed again, with the same symptoms.

My question is; is this symptomatic of a hard drive failure (considering the healthy SMART status and fact I can read the drive's data in Ubuntu) or is it just buggy RAID software in the NAS? I would ordinarily blame the drive, but the NAS *is* extraordinarily buggy so I don't really trust it not to waste my time.

Are there any good tools that would diagnose a drive failure - I was thinking of using Seagate's SeaTools with the drive in a USB disk caddy but wonder if it would get confused with the filesystem on the drive considering it's for Windows/DOS only.

Any advice gratefully received...

How do you know it's the NSA which you did say was working fine. Are you use the firmware update supports 3Tb..
Reply With Quote
  #3  
Old 02-26-2013, 03:33 PM
dotdavid dotdavid is offline
New Member
 
Join Date: Feb 2013
Posts: 5
Thanks: 2
Thanked 0 Times in 0 Posts
dotdavid is just starting out
Default

Quote:
Originally Posted by tipstir View Post
How do you know it's the NSA which you did say was working fine. Are you use the firmware update supports 3Tb..
Hi, I'm definitely on the 3TB-supporting firmware, but some people I've been speaking to say it might be something to do with the RAID implementation and/or XFS file system. I'm going to try it with a JBOD configuration using one drive as master and backing up regularly to the other drive, to see if that is any more stable.
Reply With Quote
  #4  
Old 12-29-2014, 08:07 AM
alison3492 alison3492 is offline
New Member
 
Join Date: Dec 2014
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
alison3492 is just starting out
Default

Thank you Tim and I have adopted your advice re password protecting the relevent folders on the NAS. My apologises for the slow feedback, which ahd been due to illness.



___________________


Subscribe for ccna exam questions dumps training sessions to guarantee pass microsoft office specialist certification Also get free download link for the next Testking after getting success in www.ndm.edu ccent training, you can find a wonderful job at Benjamin Franklin Institute of Technology

Last edited by alison3492; 01-12-2015 at 02:16 PM.
Reply With Quote
  #5  
Old 01-09-2015, 05:50 PM
bobby23 bobby23 is offline
New Member
 
Join Date: Jan 2015
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
bobby23 is just starting out
Default

Thanks.. nice share,,,
Reply With Quote
Reply

Tags
degraded, failure, nsa221, raid, zyxel

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 07:00 PM.


Top 10 Stats
Top Posters* Top Thanked
RMerlin  499
john9527  190
huotg01  170
System Error...  149
stevech  136
jegesq  130
L&LD  129
hggomes  104
azazel1024  104
RussellInCinc...  64
RMerlin  6898
john9527  654
stevech  373
ryzhov_al  311
L&LD  273
TeHashX  270
RogerSC  208
hggomes  171
sinshiva  156
sfx2000  145
Most Viewed Threads* Hottest Threads*
Old Asuswrt-Merli...  20292
Old SECURITY:...  18381
Old ASUS...  10558
Old ASUS...  7507
Old ASUS...  6837
Old choose a new...  3111
Old Asuswrt-Merli...  2466
Old Bulding...  2253
Old Horrible...  2073
Old Upgraded to...  1752
Old Asuswrt-Merli...  200
Old SECURITY:...  74
Old choose a new...  73
Old ASUS...  59
Old What is dual...  43
Old ASUS...  43
Old Using a UPS...  30
Old ASUS...  29
Old Need a...  27
Old Equipment...  26


Powered by vBulletin® Version 3.7.3
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
© 2006-2015 Pudai LLC All Rights Reserved.