SmallNetBuilder Forums
Go Back   SmallNetBuilder Forums > Wireless Networking > ASUS Wireless > Asuswrt-Merlin

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 02-04-2013, 02:11 PM
mmmmmm mmmmmm is offline
Member
 
Join Date: Nov 2012
Posts: 35
Thanks: 24
Thanked 3 Times in 2 Posts
mmmmmm is just starting out
Default ipkg: can't resolve symbol '__ctype_b_loc'

Hi,

after installing the following components (on my attempt to install gallery):
- lighttpd
- mysql
- php (with serveral extensions: ctype, mbstring, xml, json, iconv, filter ...)

it seems they broke my environment.

When running ipkg list I get the error:
Code:
admin@RT-N66U:/tmp/mnt/sda1# ipkg update
ipkg: can't resolve symbol '__ctype_b_loc'
When trying to run transmission daemon I get:
Code:
admin@RT-N66U:/tmp/mnt/sda1# /opt/etc/init.d/S95transmission start
Starting transmission-daemon:.[20:11:09.694] Couldn't read "/opt/etc/transmission-daemon/settings.json": Not a regular file
[FAILED]
Can anyone please give some pointers on what went wrong and how to fix these.

I actually managed to get the lighttpd and php running. Also the mySql was ok.

Thank you

Last edited by mmmmmm; 02-04-2013 at 02:15 PM.
Reply With Quote
  #2  
Old 02-05-2013, 04:20 AM
mmmmmm mmmmmm is offline
Member
 
Join Date: Nov 2012
Posts: 35
Thanks: 24
Thanked 3 Times in 2 Posts
mmmmmm is just starting out
Default

I realize that this is Linux related (not Asus, RT-N66U or Merlin's version), but can anyone please provide some assistance?

Is it possible that a firmware rewrite/upgrade will solve this?
Reply With Quote
  #3  
Old 02-06-2013, 11:25 PM
RMerlin's Avatar
RMerlin RMerlin is offline
Very Senior Member
 
Join Date: Apr 2012
Location: Canada
Posts: 11,218
Thanks: 58
Thanked 6,293 Times in 2,565 Posts
RMerlin is just starting out
Default

The problem seem to be with your Optware/Entware repo. I'm not really an expert at fixing package conflicts, best I could suggest is to rename your current asusware directory (or whatever directory contains your Entware filesystem), reboot, and restart from scratch. You can copy back any customized file from the backup you made before rebooting.
__________________
Asuswrt-Merlin: Customized firmware for Asus routers
Github: github.com/RMerl - Twitter: RMerlinDev
See the sticky post for more info.
Reply With Quote
The Following User Says Thank You to RMerlin For This Useful Post:
  #4  
Old 02-07-2013, 02:19 AM
mmmmmm mmmmmm is offline
Member
 
Join Date: Nov 2012
Posts: 35
Thanks: 24
Thanked 3 Times in 2 Posts
mmmmmm is just starting out
Default

Quote:
Originally Posted by RMerlin View Post
The problem seem to be with your Optware/Entware repo.
You are absolutely right.
I realized that I combined packages from optware & entware.
I simply removed the asusware directory and reinstalled everything from scratch, but this time only entware packages. Now everything is ok.

Thank you very much, RMerlin!
Reply With Quote
  #5  
Old 02-07-2013, 02:22 AM
mmmmmm mmmmmm is offline
Member
 
Join Date: Nov 2012
Posts: 35
Thanks: 24
Thanked 3 Times in 2 Posts
mmmmmm is just starting out
Default

Quote:
Originally Posted by mmmmmm View Post
I realize that this is Linux related (not Asus, RT-N66U or Merlin's version), but can anyone please provide some assistance?

Is it possible that a firmware rewrite/upgrade will solve this?
To whom it might interest:
The firmware upgrade did not solve the issue (I lost jffs contents in the upggrade process )

The problem was, as Merlin stated, mixing Optware/Entware repositories.
The solution was a clean reinstall only from Entware.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 02:36 AM.


Top 10 Stats
Top Posters* Top Thanked
RMerlin  394
azazel1024  130
L&LD  111
john9527  100
htismaqe  97
stevech  79
ColinTaylor  76
hggomes  55
sfx2000  51
Anzaia  47
RMerlin  6292
john9527  461
stevech  353
ryzhov_al  289
TeHashX  253
L&LD  243
RogerSC  203
sinshiva  146
sfx2000  136
joegreat  127
Most Viewed Threads* Hottest Threads*
Old Asuswrt-Merli...  56778
Old RT-AC68 -...  25002
Old Moderate Nat...  5428
Old ASUS RT-N66U...  4927
Old iOS 8.1...  4208
Old RT-AC87U -...  2747
Old RT-AC68P QOS...  2257
Old New AC68...  2179
Old AC68U,...  2083
Old Ruckus...  1883
Old Asuswrt-Merli...  252
Old RT-AC68 -...  141
Old Review: 24...  35
Old Moderate Nat...  34
Old iOS 8.1...  33
Old RT-AC87U -...  26
Old RT-AC68P QOS...  24
Old How to flash...  24
Old Linksys...  21
Old Help Plz:...  21


Powered by vBulletin® Version 3.7.3
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
© 2006-2014 Pudai LLC All Rights Reserved.