SmallNetBuilder Forums
Go Back   SmallNetBuilder Forums > Wireless Networking > ASUS Wireless > Asuswrt-Merlin

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 02-04-2013, 02:11 PM
mmmmmm mmmmmm is offline
Member
 
Join Date: Nov 2012
Posts: 35
Thanks: 24
Thanked 4 Times in 2 Posts
mmmmmm is just starting out
Default ipkg: can't resolve symbol '__ctype_b_loc'

Hi,

after installing the following components (on my attempt to install gallery):
- lighttpd
- mysql
- php (with serveral extensions: ctype, mbstring, xml, json, iconv, filter ...)

it seems they broke my environment.

When running ipkg list I get the error:
Code:
admin@RT-N66U:/tmp/mnt/sda1# ipkg update
ipkg: can't resolve symbol '__ctype_b_loc'
When trying to run transmission daemon I get:
Code:
admin@RT-N66U:/tmp/mnt/sda1# /opt/etc/init.d/S95transmission start
Starting transmission-daemon:.[20:11:09.694] Couldn't read "/opt/etc/transmission-daemon/settings.json": Not a regular file
[FAILED]
Can anyone please give some pointers on what went wrong and how to fix these.

I actually managed to get the lighttpd and php running. Also the mySql was ok.

Thank you

Last edited by mmmmmm; 02-04-2013 at 02:15 PM.
Reply With Quote
  #2  
Old 02-05-2013, 04:20 AM
mmmmmm mmmmmm is offline
Member
 
Join Date: Nov 2012
Posts: 35
Thanks: 24
Thanked 4 Times in 2 Posts
mmmmmm is just starting out
Default

I realize that this is Linux related (not Asus, RT-N66U or Merlin's version), but can anyone please provide some assistance?

Is it possible that a firmware rewrite/upgrade will solve this?
Reply With Quote
  #3  
Old 02-06-2013, 11:25 PM
RMerlin's Avatar
RMerlin RMerlin is offline
Very Senior Member
 
Join Date: Apr 2012
Location: Canada
Posts: 12,166
Thanks: 66
Thanked 6,937 Times in 2,817 Posts
RMerlin is just starting out
Default

The problem seem to be with your Optware/Entware repo. I'm not really an expert at fixing package conflicts, best I could suggest is to rename your current asusware directory (or whatever directory contains your Entware filesystem), reboot, and restart from scratch. You can copy back any customized file from the backup you made before rebooting.
__________________
Asuswrt-Merlin: Customized firmware for Asus routers
Github: github.com/RMerl - Twitter: RMerlinDev
See the sticky post for more info.
Reply With Quote
The Following User Says Thank You to RMerlin For This Useful Post:
  #4  
Old 02-07-2013, 02:19 AM
mmmmmm mmmmmm is offline
Member
 
Join Date: Nov 2012
Posts: 35
Thanks: 24
Thanked 4 Times in 2 Posts
mmmmmm is just starting out
Default

Quote:
Originally Posted by RMerlin View Post
The problem seem to be with your Optware/Entware repo.
You are absolutely right.
I realized that I combined packages from optware & entware.
I simply removed the asusware directory and reinstalled everything from scratch, but this time only entware packages. Now everything is ok.

Thank you very much, RMerlin!
Reply With Quote
  #5  
Old 02-07-2013, 02:22 AM
mmmmmm mmmmmm is offline
Member
 
Join Date: Nov 2012
Posts: 35
Thanks: 24
Thanked 4 Times in 2 Posts
mmmmmm is just starting out
Default

Quote:
Originally Posted by mmmmmm View Post
I realize that this is Linux related (not Asus, RT-N66U or Merlin's version), but can anyone please provide some assistance?

Is it possible that a firmware rewrite/upgrade will solve this?
To whom it might interest:
The firmware upgrade did not solve the issue (I lost jffs contents in the upggrade process )

The problem was, as Merlin stated, mixing Optware/Entware repositories.
The solution was a clean reinstall only from Entware.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 05:32 PM.


Top 10 Stats
Top Posters* Top Thanked
RMerlin  532
john9527  190
System Error...  171
huotg01  166
stevech  148
L&LD  142
jegesq  130
hggomes  89
azazel1024  89
RussellInCinc...  71
RMerlin  6936
john9527  660
stevech  374
ryzhov_al  311
L&LD  275
TeHashX  271
RogerSC  211
hggomes  173
sinshiva  156
sfx2000  145
Most Viewed Threads* Hottest Threads*
Old Asuswrt-Merli...  40666
Old SECURITY:...  18600
Old ASUS...  10806
Old ASUS...  7975
Old Asus...  3515
Old choose a new...  3401
Old Bulding...  2314
Old Horrible...  2128
Old What is dual...  1813
Old Upgraded to...  1781
Old Asuswrt-Merli...  334
Old Asus...  95
Old SECURITY:...  74
Old choose a new...  73
Old ASUS...  59
Old What is dual...  44
Old ASUS...  43
Old Can you help...  40
Old How to build...  31
Old Using a UPS...  30


Powered by vBulletin® Version 3.7.3
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
© 2006-2015 Pudai LLC All Rights Reserved.