SmallNetBuilder Forums
Go Back   SmallNetBuilder Forums > Wireless Networking > ASUS Wireless > ASUS N Routers & Adapters

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 01-09-2013, 09:24 AM
ilium007 ilium007 is offline
Member
 
Join Date: Dec 2012
Posts: 50
Thanks: 0
Thanked 2 Times in 2 Posts
ilium007 is just starting out
Default Cant connect iOS device to wifi when WAN is down

I noticed this tonight on a clients home router. When the WAN interface is down I couldnt connect an iPhone to the wifi network:

ImageUploadedByTapatalk HD1357741180.842938.jpg

So I could authenticate normally to the wifi network but then it pushed me to this log on page (for what reason I have no idea). I wanted to connect to the internal wifi to stream music to a wired network device and dont know why I was being prompted with this Asus page.

Any ideas ?

Sent from my iPad using Tapatalk HD

Last edited by ilium007; 01-09-2013 at 09:55 AM.
Reply With Quote
  #2  
Old 01-09-2013, 08:48 PM
guipel guipel is offline
New Member
 
Join Date: Aug 2012
Location: Brazil
Posts: 29
Thanks: 3
Thanked 0 Times in 0 Posts
guipel is just starting out
Default

Same behaviour here.
This is annoying because we could connect iOS apps to some services on local network.

However, I guess this is more related to iOS to Asus router.

Waiting for the experts...
Reply With Quote
  #3  
Old 01-10-2013, 01:30 AM
RMerlin's Avatar
RMerlin RMerlin is offline
Very Senior Member
 
Join Date: Apr 2012
Location: Canada
Posts: 10,767
Thanks: 55
Thanked 6,033 Times in 2,457 Posts
RMerlin is just starting out
Default

Asus did some iOS-related fixes about Internet detection with 3.0.0.4.266 (only available for the RT-AC66U at this time). You could try my firmware for the RT-N66U, which also includes those iOS fixes they did.
__________________
Asuswrt-Merlin: Customized firmware for Asus routers
Github: github.com/RMerl - Twitter: RMerlinDev
See the sticky post for more info.
Reply With Quote
  #4  
Old 01-10-2013, 06:46 AM
ilium007 ilium007 is offline
Member
 
Join Date: Dec 2012
Posts: 50
Thanks: 0
Thanked 2 Times in 2 Posts
ilium007 is just starting out
Default

I have been running your firmware since day one on this RT-66U.


Sent from my iPad using Tapatalk HD
Reply With Quote
  #5  
Old 01-10-2013, 09:51 AM
RMerlin's Avatar
RMerlin RMerlin is offline
Very Senior Member
 
Join Date: Apr 2012
Location: Canada
Posts: 10,767
Thanks: 55
Thanked 6,033 Times in 2,457 Posts
RMerlin is just starting out
Default

Quote:
Originally Posted by ilium007 View Post
I have been running your firmware since day one on this RT-66U.
But have you upgraded to 266.23b?
__________________
Asuswrt-Merlin: Customized firmware for Asus routers
Github: github.com/RMerl - Twitter: RMerlinDev
See the sticky post for more info.
Reply With Quote
  #6  
Old 01-10-2013, 04:30 PM
ilium007 ilium007 is offline
Member
 
Join Date: Dec 2012
Posts: 50
Thanks: 0
Thanked 2 Times in 2 Posts
ilium007 is just starting out
Default

Quote:
Originally Posted by RMerlin View Post
But have you upgraded to 266.23b?
No I hadn't sorry. I upgraded last night and the my dnsmasq.conf.add seemed to stop working so I rolled back. Will investigate further tonight.


Sent from my iPad using Tapatalk HD
Reply With Quote
  #7  
Old 01-10-2013, 11:22 PM
RMerlin's Avatar
RMerlin RMerlin is offline
Very Senior Member
 
Join Date: Apr 2012
Location: Canada
Posts: 10,767
Thanks: 55
Thanked 6,033 Times in 2,457 Posts
RMerlin is just starting out
Default

Quote:
Originally Posted by ilium007 View Post
No I hadn't sorry. I upgraded last night and the my dnsmasq.conf.add seemed to stop working so I rolled back. Will investigate further tonight.


Sent from my iPad using Tapatalk HD
The iOS fix is only in build 266.xx.

Just tested dnsmasq.conf.add and it works fine here:

Quote:
admin@RT-N66U:/tmp/home/root# cat /jffs/configs/dnsmasq.conf.add
interface=ppp0

admin@RT-N66U:/tmp/home/root# tail /etc/dnsmasq.conf -n 3
interface=tun21
interface=ppp0
__________________
Asuswrt-Merlin: Customized firmware for Asus routers
Github: github.com/RMerl - Twitter: RMerlinDev
See the sticky post for more info.
Reply With Quote
  #8  
Old 01-10-2013, 11:24 PM
ilium007 ilium007 is offline
Member
 
Join Date: Dec 2012
Posts: 50
Thanks: 0
Thanked 2 Times in 2 Posts
ilium007 is just starting out
Default

Quote:
Originally Posted by RMerlin View Post
The iOS fix is only in build 266.xx.

Just tested dnsmasq.conf.add and it works fine here:
Ok cool - I'll test again tonight.


Sent from my iPad using Tapatalk HD
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 10:28 AM.


Top 10 Stats
Top Posters* Top Thanked
RMerlin  359
john9527  151
azazel1024  111
stevech  103
htismaqe  99
sfx2000  81
L&LD  75
TonyH  61
ColinTaylor  53
AndreyPopov  53
RMerlin  6032
john9527  378
stevech  350
ryzhov_al  279
TeHashX  233
L&LD  232
RogerSC  199
sinshiva  147
sfx2000  133
joegreat  126
Most Viewed Threads* Hottest Threads*
Old Asuswrt-Merli...  16084
Old Brainstorming...  2350
Old RT-AC68P  2241
Old Looking for...  2135
Old Advice on...  2132
Old RT-AC68U...  1544
Old Asus...  1518
Old Issues...  1445
Old AC-68...  1368
Old Does Auto...  1246
Old Asuswrt-Merli...  123
Old Advice on...  49
Old Brainstorming...  47
Old Looking for...  35
Old Stable...  25
Old Issues...  25
Old WiFi Rates  23
Old RT-AC68U...  22
Old Belkin Pre-N...  21
Old Is restoring...  18


Powered by vBulletin® Version 3.7.3
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
© 2006-2014 Pudai LLC All Rights Reserved.