SmallNetBuilder Forums
Go Back   SmallNetBuilder Forums > Wireless Networking > ASUS Wireless > Asuswrt-Merlin

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 01-07-2013, 07:57 AM
davewolfs davewolfs is offline
New Member
 
Join Date: Jan 2013
Posts: 24
Thanks: 0
Thanked 0 Times in 0 Posts
davewolfs is just starting out
Default OpenVPN incredibly slow compared to PPTP

I have an issue with OpenVPN on slow connections. It is significantly slower than the routers built in PPTP. To the point that it is simply not usable for certain things eg VNC/RDP.

I don't know if this is the nature of the protocol or how I have set things up.

I do see the following warnings from my client logs:

NOTE: Options consistency check may be skewed by version differences
WARNING: 'version' is used inconsistently, local='version V4', remote='version V0 UNDEF'
WARNING: 'dev-type' is present in local config but missing in remote config, local='dev-type tun'
WARNING: 'link-mtu' is present in local config but missing in remote config, local='link-mtu 1560'
WARNING: 'tun-mtu' is present in local config but missing in remote config, local='tun-mtu 1500'
WARNING: 'proto' is present in local config but missing in remote config, local='proto TCPv4_SERVER'
WARNING: 'comp-lzo' is present in local config but missing in remote config, local='comp-lzo'

Is it possible that compression is not being used?
Reply With Quote
  #2  
Old 01-07-2013, 08:21 AM
davewolfs davewolfs is offline
New Member
 
Join Date: Jan 2013
Posts: 24
Thanks: 0
Thanked 0 Times in 0 Posts
davewolfs is just starting out
Default

Well here is a solution.

The tutorial here:

http://www.howtogeek.com/60774/conne...pn-and-tomato/

Shows the usage of TCP as the desired protocol. Changing to UDP seems to have completely resolved the issue.
Reply With Quote
  #3  
Old 01-07-2013, 10:48 AM
rlcronin rlcronin is offline
Member
 
Join Date: Sep 2010
Posts: 87
Thanks: 5
Thanked 2 Times in 2 Posts
rlcronin is just starting out
Default

Quote:
Originally Posted by davewolfs View Post
Well here is a solution.

The tutorial here:

http://www.howtogeek.com/60774/conne...pn-and-tomato/

Shows the usage of TCP as the desired protocol. Changing to UDP seems to have completely resolved the issue.
So I tried switching to UDP as a test, and when connecting from my Android phone from outside my local LAN (turned off WIFI and just used 4G) it seemed to work OK. But then I tried some test clients on my LAN and it would not connect. The log showed packets being rejected with a message suggesting I needed to remove a "remote" option. I researched that and found advice to change the "client" in my config file to "float". I did that but that failed as well. Any ideas?
--
bc
Reply With Quote
  #4  
Old 01-07-2013, 12:01 PM
rlcronin rlcronin is offline
Member
 
Join Date: Sep 2010
Posts: 87
Thanks: 5
Thanked 2 Times in 2 Posts
rlcronin is just starting out
Default

Quote:
Originally Posted by rlcronin View Post
So I tried switching to UDP as a test, and when connecting from my Android phone from outside my local LAN (turned off WIFI and just used 4G) it seemed to work OK. But then I tried some test clients on my LAN and it would not connect. The log showed packets being rejected with a message suggesting I needed to remove a "remote" option. I researched that and found advice to change the "client" in my config file to "float". I did that but that failed as well. Any ideas?
--
bc
I discovered that to make it work from inside my LAN I had to replace the server IP with its local IP (e.g. it is normally set to nnnnnnnn.asuscomm.com, to get a client to connect from inside the LAN when the protocol is UDP, I have to set it to 192.168.1.1). It'd be nice if there were some way to configure the client so that it would just work whether I am inside or outside the LAN (e.g. some config parameter in the server to tell it that 192.168.1.1 is equivalent to whatever nnnnnnnn.asuscomm.com resolves to).
--
bc
Reply With Quote
  #5  
Old 01-07-2013, 02:19 PM
RMerlin's Avatar
RMerlin RMerlin is offline
Very Senior Member
 
Join Date: Apr 2012
Location: Canada
Posts: 10,314
Thanks: 54
Thanked 5,753 Times in 2,352 Posts
RMerlin is just starting out
Default

Quote:
Originally Posted by rlcronin View Post
I discovered that to make it work from inside my LAN I had to replace the server IP with its local IP (e.g. it is normally set to nnnnnnnn.asuscomm.com, to get a client to connect from inside the LAN when the protocol is UDP, I have to set it to 192.168.1.1). It'd be nice if there were some way to configure the client so that it would just work whether I am inside or outside the LAN (e.g. some config parameter in the server to tell it that 192.168.1.1 is equivalent to whatever nnnnnnnn.asuscomm.com resolves to).
--
bc
Try creating a custom hosts file with an entry containing your IP and your hostname. See the Wiki for info on how to use custom config files. It should hopefully override any DNS entry.
__________________
Asuswrt-Merlin: Customized firmware for Asus routers
Github: github.com/RMerl - Twitter: RMerlinDev
See the sticky post for more info.
Reply With Quote
  #6  
Old 01-07-2013, 02:35 PM
RMerlin's Avatar
RMerlin RMerlin is offline
Very Senior Member
 
Join Date: Apr 2012
Location: Canada
Posts: 10,314
Thanks: 54
Thanked 5,753 Times in 2,352 Posts
RMerlin is just starting out
Default

Performance-wise, OpenVPN will always be slower than PPTP because it uses much stronger encryption. There are ways you can limit the performance impact tho (for my own use, the RDesktop performance is pretty close to what it used to be when I was using PPTP).

- Limit your keys to 1024 bits (anything higher is overkill and will degrade performance)
- Stick with one of the AES encryption codecs as these are optimized in the OpenSSL implementation of Asuswrt-Merlin
__________________
Asuswrt-Merlin: Customized firmware for Asus routers
Github: github.com/RMerl - Twitter: RMerlinDev
See the sticky post for more info.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 08:52 PM.


Top 10 Stats
Top Posters* Top Thanked
RMerlin  370
john9527  139
stevech  139
azazel1024  121
hggomes  99
sfx2000  84
noric  77
KGB7  71
F5ing  67
Kel-L  65
RMerlin  5752
stevech  334
john9527  276
ryzhov_al  271
TeHashX  226
L&LD  197
RogerSC  195
sinshiva  146
joegreat  127
sfx2000  124
Most Viewed Threads* Hottest Threads*
Old Asuswrt-Merli...  65422
Old Asuswrt-Merli...  11746
Old My...  4982
Old Asuswrt-Merli...  3976
Old Most stable...  3956
Old Thinking of...  3672
Old RT-AC87R (U)...  3299
Old Connection...  2950
Old [HOW TO]...  2677
Old Second new...  2019
Old Asuswrt-Merli...  262
Old Asuswrt-Merli...  116
Old Connection...  59
Old My...  56
Old [HOW TO]...  50
Old RT-AC87R (U)...  38
Old Most stable...  29
Old USB N...  29
Old New...  28
Old Second new...  27


Powered by vBulletin® Version 3.7.3
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
© 2006-2014 Pudai LLC All Rights Reserved.