SmallNetBuilder Forums
Go Back   SmallNetBuilder Forums > Wireless Networking > ASUS Wireless > Asuswrt-Merlin

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 01-22-2013, 08:28 PM
ingenium ingenium is offline
New Member
 
Join Date: Jan 2013
Posts: 4
Thanks: 0
Thanked 4 Times in 2 Posts
ingenium is just starting out
Default Layer7 broken?

Whenever I try to add an iptables rule with layer7, such as:

Code:
iptables -t mangle -A QOSO -p tcp -m layer7 --l7proto bittorrent -j CONNMARK --set-return 0x5/0xff
it returns:

Code:
iptables: No chain/target/match by that name
I can't see a layer7 module loaded, so maybe it's compiled into the kernel? If I try to change l7proto to something else, say "test", it returns:

Code:
iptables v1.3.8: Couldn't find a pattern definition file for test.
So it's clearly finding the pattern rules in /etc/l7-protocols/. There must be some other problem going on.

EDIT: I may as well ask another related question in the same thread. If I want to add custom QoS rules, should I have it in the firewall-start script or the nat-start script? Or does it not matter? Basically I don't want the rules being re-added if the mangle table hasn't been flushed... does adding a port forward via the webui just flush the nat table or does it re-load the whole firewall?

Last edited by ingenium; 01-22-2013 at 09:28 PM.
Reply With Quote
  #2  
Old 01-25-2013, 06:09 AM
ingenium ingenium is offline
New Member
 
Join Date: Jan 2013
Posts: 4
Thanks: 0
Thanked 4 Times in 2 Posts
ingenium is just starting out
Default

I found the directory where all the kernel modules are, and there was a layer7 module in there. Running "modprobe xt_layer7" fixed the issue.
Reply With Quote
The Following 3 Users Say Thank You to ingenium For This Useful Post:
  #3  
Old 02-28-2014, 01:34 PM
yelo3 yelo3 is offline
New Member
 
Join Date: Feb 2014
Posts: 26
Thanks: 0
Thanked 0 Times in 0 Posts
yelo3 is just starting out
Default

Any suggestion on how to block p2p instead of marking it for QOS?
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 02:39 AM.


Top 10 Stats
Top Posters* Top Thanked
RMerlin  365
john9527  148
azazel1024  134
stevech  117
htismaqe  99
L&LD  97
sfx2000  77
TonyH  72
AndreyPopov  56
ChristineBCW  54
RMerlin  6019
john9527  374
stevech  349
ryzhov_al  277
TeHashX  232
L&LD  231
RogerSC  199
sinshiva  147
sfx2000  133
joegreat  126
Most Viewed Threads* Hottest Threads*
Old Shellshock...  27519
Old Asuswrt-Merli...  11226
Old Antenna...  3915
Old Simple NAS...  2398
Old Brainstorming...  2204
Old Looking for...  1969
Old RT-AC68P  1884
Old Advice on...  1626
Old RT-AC68U...  1394
Old Asus...  1321
Old Asuswrt-Merli...  94
Old Antenna...  73
Old Brainstorming...  47
Old Advice on...  47
Old Simple NAS...  36
Old Looking for...  35
Old Shellshock...  31
Old Stable...  25
Old Issues...  24
Old WiFi Rates  23


Powered by vBulletin® Version 3.7.3
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
© 2006-2014 Pudai LLC All Rights Reserved.