SmallNetBuilder Forums
Go Back   SmallNetBuilder Forums > Wireless Networking > ASUS Wireless > Asuswrt-Merlin

Reply
 
Thread Tools Search this Thread Display Modes
  #321  
Old 08-16-2014, 09:47 AM
LUK's Avatar
LUK LUK is online now
New Member
 
Join Date: Aug 2014
Posts: 6
Thanks: 1
Thanked 0 Times in 0 Posts
LUK is just starting out
Default

Quote:
Originally Posted by TeHashX View Post
You already installed wget-ssl, continue with the next step
Thanks for your feedback,

But when I tried to '/opt/etc/init.d/S95transmission start', it displays as attachment.

Actually, I connected new USB HDD before install, is it cause this problem?
Attached Images
File Type: png Error2.png (41.4 KB, 7 views)

Last edited by LUK; 08-16-2014 at 09:51 AM.
Reply With Quote
  #322  
Old 08-16-2014, 10:02 AM
TeHashX's Avatar
TeHashX TeHashX is offline
Very Senior Member
 
Join Date: Jul 2012
Location: Europe
Posts: 574
Thanks: 134
Thanked 217 Times in 123 Posts
TeHashX is just starting out
Default

Quote:
Originally Posted by LUK View Post
Thanks for your feedback,

But when I tried to '/opt/etc/init.d/S95transmission start', it displays as attachment.

Actually, I connected new USB HDD before install, is it cause this problem?
Send outputs from:
uname -a
mount
df
free
Reply With Quote
  #323  
Old 08-16-2014, 10:08 AM
LUK's Avatar
LUK LUK is online now
New Member
 
Join Date: Aug 2014
Posts: 6
Thanks: 1
Thanked 0 Times in 0 Posts
LUK is just starting out
Default

Quote:
Originally Posted by TeHashX View Post
Send outputs from:
uname -a
mount
df
free
Plz check attachment.

Thanks.
Attached Images
File Type: png Error_3.png (56.3 KB, 10 views)
Reply With Quote
  #324  
Old 08-16-2014, 10:19 AM
TeHashX's Avatar
TeHashX TeHashX is offline
Very Senior Member
 
Join Date: Jul 2012
Location: Europe
Posts: 574
Thanks: 134
Thanked 217 Times in 123 Posts
TeHashX is just starting out
Default

ipkg install libiconv

Do you have RT-AC68 or RT-AC87?

Last edited by TeHashX; 08-16-2014 at 10:23 AM.
Reply With Quote
  #325  
Old 08-16-2014, 10:27 AM
LUK's Avatar
LUK LUK is online now
New Member
 
Join Date: Aug 2014
Posts: 6
Thanks: 1
Thanked 0 Times in 0 Posts
LUK is just starting out
Default

Quote:
Originally Posted by TeHashX View Post
ipkg install libiconv

Do you have RT-AC68 or RT-AC87?
Plz check attached result file. I have RT-AC68R.
Attached Images
File Type: png Error_4.png (37.5 KB, 8 views)
Reply With Quote
  #326  
Old 08-16-2014, 10:30 AM
TeHashX's Avatar
TeHashX TeHashX is offline
Very Senior Member
 
Join Date: Jul 2012
Location: Europe
Posts: 574
Thanks: 134
Thanked 217 Times in 123 Posts
TeHashX is just starting out
Default

Should be ok, restart router and go to 192.168.1.1:9091
Reply With Quote
  #327  
Old 08-16-2014, 11:29 AM
LUK's Avatar
LUK LUK is online now
New Member
 
Join Date: Aug 2014
Posts: 6
Thanks: 1
Thanked 0 Times in 0 Posts
LUK is just starting out
Smile

Quote:
Originally Posted by TeHashX View Post
Should be ok, restart router and go to 192.168.1.1:9091
Hi, friend.

I resolved this problem to do "factory reset". I think it is problem between old HDD with new HDD.

Thanks for your help.
BR
Reply With Quote
  #328  
Old 08-21-2014, 03:58 PM
atkinsom atkinsom is online now
Member
 
Join Date: Feb 2013
Posts: 47
Thanks: 102
Thanked 6 Times in 6 Posts
atkinsom is just starting out
Default

Quote:
Originally Posted by TeHashX View Post
SWAP FILE
If transmission crashes sometimes "without reason", most probably router goes out of memory and this can be fixed by creating a swap partition but it's a little bit to complicated for most users and we will create a swap file instead, 256MB is more than enough:
cd /opt
dd if=/dev/zero of=swapfile bs=1024 count=262144
mkswap swapfile
chmod 0600 swapfile
swapon swapfile
To enable swap file when router booting, add this lines to /jffs/scripts/post-mount script
Code:
#!/bin/sh

swapon /opt/swapfile
To unmount add this lines to /jffs/scripts/services-stop script
Code:
#!/bin/sh

swapoff /opt/swapfile
Code:
chmod a+rx /jffs/scripts/post-mount
chmod a+rx /jffs/scripts/services-stop
I've created the swap file but I'm not sure where to place the commands in the post-mount and services-stop script files. There's already script data in those files. see below for what already exists in each of those files and advise where in those scripts I can place the swapon and swapoff commands. Thanks

post-mount

#!/bin/sh

if [ $1 = "/tmp/mnt/sda1" ]
then
ln -sf $1/entware /tmp/opt
fi

services-stop

#!/bin/sh

/opt/etc/init.d/rc.unslung stop
Reply With Quote
  #329  
Old 08-22-2014, 04:56 AM
TeHashX's Avatar
TeHashX TeHashX is offline
Very Senior Member
 
Join Date: Jul 2012
Location: Europe
Posts: 574
Thanks: 134
Thanked 217 Times in 123 Posts
TeHashX is just starting out
Default

Quote:
Originally Posted by atkinsom View Post
I've created the swap file but I'm not sure where to place the commands in the post-mount and services-stop script files. There's already script data in those files. see below for what already exists in each of those files and advise where in those scripts I can place the swapon and swapoff commands. Thanks

post-mount

#!/bin/sh

if [ $1 = "/tmp/mnt/sda1" ]
then
ln -sf $1/entware /tmp/opt
fi

services-stop

#!/bin/sh

/opt/etc/init.d/rc.unslung stop
post-mount
Code:
#!/bin/sh

if [ $1 = "/tmp/mnt/sda1" ]
then
  ln -sf $1/entware /tmp/opt
fi

swapon /opt/swapfile
services-stop
Code:
#!/bin/sh

/opt/etc/init.d/rc.unslung stop
swapoff /opt/swapfile
Reply With Quote
The Following User Says Thank You to TeHashX For This Useful Post:
  #330  
Old 08-25-2014, 08:36 AM
thealphonso thealphonso is offline
New Member
 
Join Date: Dec 2012
Posts: 15
Thanks: 3
Thanked 0 Times in 0 Posts
thealphonso is just starting out
Default

How can I add a delay in post-mount script in order for the transmission-daemon to wait for USB mounting?
I'm keep getting these errors after cold boot related to ...no data is found. please add a disk...
Reply With Quote
Reply

Tags
asuswrt, howto, optware, tutorial

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 09:49 PM.


Top 10 Stats
Top Posters* Top Thanked
RMerlin  367
stevech  157
KGB7  126
Kel-L  102
sfx2000  98
azazel1024  93
sinshiva  89
john9527  81
fistv  71
hggomes  68
RMerlin  5599
stevech  329
ryzhov_al  266
TeHashX  217
L&LD  192
RogerSC  190
sinshiva  143
joegreat  127
jlake  122
sfx2000  121
Most Viewed Threads* Hottest Threads*
Old Asuswrt-Merli...  78127
Old Asuswrt-Merli...  46743
Old [Fork]...  20087
Old Asus locking...  10345
Old ASUS...  8288
Old Incoming...  8035
Old Share What...  3899
Old Asuswrt-Merli...  3372
Old Asuswrt-Merli...  3031
Old Thinking of...  2172
Old Asuswrt-Merli...  393
Old Asuswrt-Merli...  215
Old [Fork]...  136
Old Asus locking...  125
Old Connection...  55
Old [HOW TO]...  50
Old ASUS...  49
Old Incoming...  44
Old 376.44 -...  40
Old Use the same...  35


Powered by vBulletin® Version 3.7.3
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
© 2006-2014 Pudai LLC All Rights Reserved.