SmallNetBuilder Forums
Go Back   SmallNetBuilder Forums > NAS > General NAS Discussion

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 02-21-2013, 07:17 AM
phreak phreak is offline
New Member
 
Join Date: Feb 2013
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
phreak is just starting out
Default Remote NFS mount onto Freenas

Hi there,

I posted this question to the Freenas forum but as of yet they have not been able to help me.
The situation is this. I currently have a ClearOS box running my sites main file server. But as I want to move to setting permissions based on AD users I thought I would try out Freenas. I have managed to get my data on there for the most part and share it. However, on a seperate NAS server is some old archive data that needs to be in the same area for reference. No new data is going to be copied onto it or from it.
So what I need to do it mount this share onto my Freenas server.
I achieved this by using the following command.

mount_nfs 10.10.10.1:/share /mnt/sharepath

But the only problem is that mount gets lost when the server is rebooted. I wondered if there was any way to make this mount stick. I tried adding it to /etc/fstab but that file seems to get regenerated every time you reboot so non of my changes ever stick in there.

Is there any way to do what I need?

I also tried to Smbfs mount it with the following command.

mount_smbfs -N -I 10.10.10.1 -W workgroup //user@remote_system/share /path/to/local/mount

But to do that you need to put in a password for access and again, if I edit and put in those user details into /etc/nsmb.conf then that seems to get wiped on reboot.

Any help is greatly appreciated.
Reply With Quote
  #2  
Old 04-29-2013, 12:59 AM
travalon travalon is offline
New Member
 
Join Date: Apr 2013
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
travalon is just starting out
Default

I don't know the answer but i might suggest the freeS forums.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 05:22 AM.

Top 10 Stats
Top Posters* Top Thanked
RMerlin  363
thelonelycode...  167
stevech  152
L&LD  129
azazel1024  115
KGB7  76
Adamm  72
jim769  67
speedingcheet...  57
sm00thpapa  53
RMerlin  4455
stevech  271
ryzhov_al  199
TeHashX  194
RogerSC  165
L&LD  163
joegreat  104
jlake  100
PrivateJoker  93
sinshiva  87
Most Viewed Threads* Hottest Threads*
Old Asuswrt-Merli...  29574
Old ASUS...  19404
Old Beta Version...  17256
Old 'Heartbleed'...  13447
Old Potential...  7690
Old Linksys...  7502
Old Asus-Merlin...  6566
Old Asuswrt-Merli...  6559
Old Groundhog...  6191
Old Linksys...  4646
Old Asuswrt-Merli...  215
Old Linksys...  135
Old Beta Version...  112
Old ASUS...  110
Old Potential...  98
Old Asuswrt-Merli...  73
Old Linksys...  61
Old Groundhog...  49
Old Asus router...  43
Old New Home...  38



Powered by vBulletin® Version 3.7.3
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
© 2006-2014 Pudai LLC All Rights Reserved.