SmallNetBuilder Forums
Go Back   SmallNetBuilder Forums > Wireless Networking > ASUS Wireless > ASUS AC Routers & Adapters

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 11-30-2012, 02:36 PM
Marrus Marrus is offline
New Member
 
Join Date: Nov 2012
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Marrus is just starting out
Default SOLVED - Can't connect to CherryPy services

I run several applications which I use port forwarding to expose so I can access them from outside of my home network.

I run Air Video and Calibre, and a couple of python applications that use CherryPy as their embedded web server.

After setting up a new RT-AC66U as my router, I found that port forwarding did not work for the CherryPy-based applications. Air Video and Calibre worked without any problems.

After some more testing, I found that I can access the CherryPy apps from the PC they run on, by connecting to localhost or explicitly using the IP address.

However, I was not able to connect using the (internal) IP address from a machine (inside my home network) other than the PC running the services.

What's going on and how can I fix it?

Last edited by Marrus; 11-30-2012 at 11:40 PM. Reason: Solved
Reply With Quote
  #2  
Old 11-30-2012, 04:02 PM
Marrus Marrus is offline
New Member
 
Join Date: Nov 2012
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Marrus is just starting out
Default

The following minimal cherrypy service exhibits the problem that I described.
import cherrypy
class HelloWorld(object):
def index(self):
return "Hello World!"
index.exposed = True

cherrypy.config.update({'server.socket_port': 30596})
cherrypy.quickstart(HelloWorld())
Reply With Quote
  #3  
Old 11-30-2012, 11:45 PM
Marrus Marrus is offline
New Member
 
Join Date: Nov 2012
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Marrus is just starting out
Default

I figured out what was causing the problem.

When I was setting up the router, I apparently accidentally configured the network in Windows 7 to Public rather than Home.

I had previously configured the CherryPy services to not be accessible in a Public network.

The solution was to change the network location to Home.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 10:17 PM.


Top 10 Stats
Top Posters* Top Thanked
RMerlin  354
john9527  147
azazel1024  134
stevech  119
htismaqe  99
L&LD  98
sfx2000  76
TonyH  72
AndreyPopov  56
ChristineBCW  54
RMerlin  6016
john9527  374
stevech  349
ryzhov_al  277
TeHashX  232
L&LD  231
RogerSC  199
sinshiva  147
sfx2000  133
joegreat  126
Most Viewed Threads* Hottest Threads*
Old Shellshock...  27503
Old Asuswrt-Merli...  10826
Old Antenna...  3904
Old Simple NAS...  2392
Old Brainstorming...  2195
Old Looking for...  1961
Old RT-AC68P  1861
Old Advice on...  1603
Old RT-AC68U...  1383
Old Asus...  1304
Old Asuswrt-Merli...  86
Old Antenna...  73
Old Advice on...  47
Old Brainstorming...  47
Old Simple NAS...  36
Old Looking for...  35
Old Shellshock...  31
Old Stable...  25
Old WiFi Rates  23
Old Issues...  23


Powered by vBulletin® Version 3.7.3
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
© 2006-2014 Pudai LLC All Rights Reserved.