SmallNetBuilder Forums
Go Back   SmallNetBuilder Forums > Wireless Networking > ASUS Wireless > Asuswrt-Merlin

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 01-07-2013, 07:57 AM
davewolfs davewolfs is offline
Member
 
Join Date: Jan 2013
Posts: 31
Thanks: 0
Thanked 0 Times in 0 Posts
davewolfs is just starting out
Default OpenVPN incredibly slow compared to PPTP

I have an issue with OpenVPN on slow connections. It is significantly slower than the routers built in PPTP. To the point that it is simply not usable for certain things eg VNC/RDP.

I don't know if this is the nature of the protocol or how I have set things up.

I do see the following warnings from my client logs:

NOTE: Options consistency check may be skewed by version differences
WARNING: 'version' is used inconsistently, local='version V4', remote='version V0 UNDEF'
WARNING: 'dev-type' is present in local config but missing in remote config, local='dev-type tun'
WARNING: 'link-mtu' is present in local config but missing in remote config, local='link-mtu 1560'
WARNING: 'tun-mtu' is present in local config but missing in remote config, local='tun-mtu 1500'
WARNING: 'proto' is present in local config but missing in remote config, local='proto TCPv4_SERVER'
WARNING: 'comp-lzo' is present in local config but missing in remote config, local='comp-lzo'

Is it possible that compression is not being used?
Reply With Quote
  #2  
Old 01-07-2013, 08:21 AM
davewolfs davewolfs is offline
Member
 
Join Date: Jan 2013
Posts: 31
Thanks: 0
Thanked 0 Times in 0 Posts
davewolfs is just starting out
Default

Well here is a solution.

The tutorial here:

http://www.howtogeek.com/60774/conne...pn-and-tomato/

Shows the usage of TCP as the desired protocol. Changing to UDP seems to have completely resolved the issue.
Reply With Quote
  #3  
Old 01-07-2013, 10:48 AM
rlcronin rlcronin is offline
Member
 
Join Date: Sep 2010
Posts: 88
Thanks: 5
Thanked 2 Times in 2 Posts
rlcronin is just starting out
Default

Quote:
Originally Posted by davewolfs View Post
Well here is a solution.

The tutorial here:

http://www.howtogeek.com/60774/conne...pn-and-tomato/

Shows the usage of TCP as the desired protocol. Changing to UDP seems to have completely resolved the issue.
So I tried switching to UDP as a test, and when connecting from my Android phone from outside my local LAN (turned off WIFI and just used 4G) it seemed to work OK. But then I tried some test clients on my LAN and it would not connect. The log showed packets being rejected with a message suggesting I needed to remove a "remote" option. I researched that and found advice to change the "client" in my config file to "float". I did that but that failed as well. Any ideas?
--
bc
Reply With Quote
  #4  
Old 01-07-2013, 12:01 PM
rlcronin rlcronin is offline
Member
 
Join Date: Sep 2010
Posts: 88
Thanks: 5
Thanked 2 Times in 2 Posts
rlcronin is just starting out
Default

Quote:
Originally Posted by rlcronin View Post
So I tried switching to UDP as a test, and when connecting from my Android phone from outside my local LAN (turned off WIFI and just used 4G) it seemed to work OK. But then I tried some test clients on my LAN and it would not connect. The log showed packets being rejected with a message suggesting I needed to remove a "remote" option. I researched that and found advice to change the "client" in my config file to "float". I did that but that failed as well. Any ideas?
--
bc
I discovered that to make it work from inside my LAN I had to replace the server IP with its local IP (e.g. it is normally set to nnnnnnnn.asuscomm.com, to get a client to connect from inside the LAN when the protocol is UDP, I have to set it to 192.168.1.1). It'd be nice if there were some way to configure the client so that it would just work whether I am inside or outside the LAN (e.g. some config parameter in the server to tell it that 192.168.1.1 is equivalent to whatever nnnnnnnn.asuscomm.com resolves to).
--
bc
Reply With Quote
  #5  
Old 01-07-2013, 02:19 PM
RMerlin's Avatar
RMerlin RMerlin is online now
Very Senior Member
 
Join Date: Apr 2012
Location: Canada
Posts: 10,870
Thanks: 56
Thanked 6,060 Times in 2,471 Posts
RMerlin is just starting out
Default

Quote:
Originally Posted by rlcronin View Post
I discovered that to make it work from inside my LAN I had to replace the server IP with its local IP (e.g. it is normally set to nnnnnnnn.asuscomm.com, to get a client to connect from inside the LAN when the protocol is UDP, I have to set it to 192.168.1.1). It'd be nice if there were some way to configure the client so that it would just work whether I am inside or outside the LAN (e.g. some config parameter in the server to tell it that 192.168.1.1 is equivalent to whatever nnnnnnnn.asuscomm.com resolves to).
--
bc
Try creating a custom hosts file with an entry containing your IP and your hostname. See the Wiki for info on how to use custom config files. It should hopefully override any DNS entry.
__________________
Asuswrt-Merlin: Customized firmware for Asus routers
Github: github.com/RMerl - Twitter: RMerlinDev
See the sticky post for more info.
Reply With Quote
  #6  
Old 01-07-2013, 02:35 PM
RMerlin's Avatar
RMerlin RMerlin is online now
Very Senior Member
 
Join Date: Apr 2012
Location: Canada
Posts: 10,870
Thanks: 56
Thanked 6,060 Times in 2,471 Posts
RMerlin is just starting out
Default

Performance-wise, OpenVPN will always be slower than PPTP because it uses much stronger encryption. There are ways you can limit the performance impact tho (for my own use, the RDesktop performance is pretty close to what it used to be when I was using PPTP).

- Limit your keys to 1024 bits (anything higher is overkill and will degrade performance)
- Stick with one of the AES encryption codecs as these are optimized in the OpenSSL implementation of Asuswrt-Merlin
__________________
Asuswrt-Merlin: Customized firmware for Asus routers
Github: github.com/RMerl - Twitter: RMerlinDev
See the sticky post for more info.
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 10:26 AM.


Top 10 Stats
Top Posters* Top Thanked
RMerlin  402
john9527  157
azazel1024  111
htismaqe  102
sfx2000  81
stevech  76
ColinTaylor  65
AndreyPopov  57
TonyH  56
bbb0777  42
RMerlin  6059
john9527  389
stevech  351
ryzhov_al  280
TeHashX  237
L&LD  232
RogerSC  201
sinshiva  147
sfx2000  134
joegreat  126
Most Viewed Threads* Hottest Threads*
Old Asuswrt-Merli...  28209
Old Brainstorming...  2626
Old Advice on...  2570
Old Looking for...  2350
Old RT-AC68P...  2268
Old RT-AC68U...  1863
Old Asus...  1790
Old Issues...  1760
Old Stable...  1647
Old AC-68...  1599
Old Asuswrt-Merli...  204
Old Advice on...  49
Old Brainstorming...  47
Old Looking for...  35
Old RT-AC68P...  28
Old WiFi...  27
Old Stable...  25
Old Issues...  25
Old WiFi Rates  23
Old RT-AC68U...  22


Powered by vBulletin® Version 3.7.3
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
© 2006-2014 Pudai LLC All Rights Reserved.