SmallNetBuilder Forums
Go Back   SmallNetBuilder Forums > Wireless Networking > ASUS Wireless > Asuswrt-Merlin

Reply
 
Thread Tools Search this Thread Display Modes
  #1  
Old 01-17-2013, 09:17 PM
rlcronin rlcronin is offline
Member
 
Join Date: Sep 2010
Posts: 81
Thanks: 5
Thanked 2 Times in 2 Posts
rlcronin is just starting out
Default Use custom DNS and not my ISP's DNS

I want to always use OpenDNS. I've configured the primary OpenDNS server on my DHCP client configuration page. My clients report that they're using that server and 192.168.1.1 as their DNS servers. The router does have my ISP's two DNS servers listed on the Internet Status page. I have observed that my clients are only using the OpenDNS server *sometimes* (by going to welcome.opendns.com and 1 minute being told that I am using OpenDNS and then going there again a few minutes later and being told I am *not* using OpenDNS).

I presume this is because the client has both the OpenDNS server address and the router address as DNS servers (i.e. when the query goes to the router's address, the router is sending it off to my ISP and when that response comes back first, it gets used in preference to the one from OpenDNS?).

I just want to always use OpenDNS and never my ISP's DNS. How can I make that happen? Is there a way to configure DNS IP addresses in the router that will always be used instead of the ones it gets from my ISP?
--
bc
Reply With Quote
  #2  
Old 01-18-2013, 06:22 AM
r.rebergen r.rebergen is offline
New Member
 
Join Date: Jan 2013
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
r.rebergen is just starting out
Default

I assume your setup is incorrect. You need to configure the OpenDNS DNS servers on the WAN page. Every client within the network then needs to connect to your router's IP for DNS requests. I think the mixup is caused by your ISP's DNS adresses.
In my case this is set up as described and works flawless!

Last edited by r.rebergen; 01-18-2013 at 06:25 AM.
Reply With Quote
  #3  
Old 01-18-2013, 11:08 AM
rlcronin rlcronin is offline
Member
 
Join Date: Sep 2010
Posts: 81
Thanks: 5
Thanked 2 Times in 2 Posts
rlcronin is just starting out
Default

Quote:
Originally Posted by r.rebergen View Post
I assume your setup is incorrect. You need to configure the OpenDNS DNS servers on the WAN page. Every client within the network then needs to connect to your router's IP for DNS requests. I think the mixup is caused by your ISP's DNS adresses.
In my case this is set up as described and works flawless!
D'oh! Ok, this was caused by me not understanding the meaning of the "Connect to DNS server automatically" option on the WAN page. I had noticed there was no place to manually specify DNS servers on that page. It just never dawned on me that I had to uncheck that option to get the server fields to appear. Thanks for the nudge ...
--
bc
Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 06:00 PM.

Top 10 Stats
Top Posters* Top Thanked
RMerlin  367
thelonelycode...  167
stevech  148
L&LD  128
azazel1024  112
KGB7  78
Adamm  71
jim769  71
speedingcheet...  57
sm00thpapa  51
RMerlin  4461
stevech  271
ryzhov_al  199
TeHashX  194
RogerSC  165
L&LD  163
joegreat  105
jlake  100
PrivateJoker  93
sinshiva  87
Most Viewed Threads* Hottest Threads*
Old Asuswrt-Merli...  30048
Old ASUS...  19743
Old Beta Version...  17296
Old 'Heartbleed'...  13567
Old Asuswrt-Merli...  9163
Old Linksys...  7740
Old Potential...  7706
Old Asus-Merlin...  6637
Old Groundhog...  6217
Old Linksys...  4680
Old Asuswrt-Merli...  215
Old Linksys...  137
Old Beta Version...  112
Old ASUS...  110
Old Potential...  98
Old Asuswrt-Merli...  89
Old Linksys...  61
Old Groundhog...  49
Old Asus router...  43
Old New Home...  38



Powered by vBulletin® Version 3.7.3
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
© 2006-2014 Pudai LLC All Rights Reserved.