SmallNetBuilder Forums

SmallNetBuilder Forums (http://forums.smallnetbuilder.com/index.php)
-   Asuswrt-Merlin (http://forums.smallnetbuilder.com/forumdisplay.php?f=42)
-   -   Phoenix, Smartreader for oscam are mounted lika a modem 3G/4G (http://forums.smallnetbuilder.com/showthread.php?t=13830)

MiCk 11-21-2013 05:25 PM

Phoenix, Smartreader for oscam are mounted lika a modem 3G/4G
 
At the beginning, I would like to say hello.

Merlin Software I use a few days. Previously I worked on Tomato by Shibby almost an year.

So I have a problem as the topic. I would like to run OSCAM server.
Now on Merlin I have problem with the mount reader: phoenix or smargo.
They are recognized as 3G/4G modem and oscam does not start.

[QUOTE]
usbcore: registered new interface driver usbserial
drivers/usb/serial/usb-serial.c: USB Serial support registered for generic
usbcore: registered new interface driver usbserial_generic
drivers/usb/serial/usb-serial.c: USB Serial Driver core
drivers/usb/serial/usb-serial.c: USB Serial support registered for GSM modem (1-port)
option 1-1.1:1.0: GSM modem (1-port) converter detected
usb 1-1.1: GSM modem (1-port) converter now attached to ttyUSB0
usbcore: registered new interface driver option
drivers/usb/serial/option.c: USB Driver for GSM modems: v0.7.2
[/QUOTE]

I doesn't have any idea why it happends ?

I tried manualy add records to run modules usbserial and ftdi_sio but always after restart router readers are mounted like modem.

Maybe some one have some idea how to solve it?

Nerre 11-22-2013 06:43 AM

Does it not work to tell oscam to use /dev/ttyUSB0 as the device??

Genereally GSM modems are treated just like any serial device, so that the log says it's a GSM modem shouldn't matter.

ryzhov_al 11-22-2013 07:20 AM

An option.ko got dynamic slot which Asus uses in following hack: every device with serial endpoint is to be handled by option.ko. Unload option.ko and load appropriate modules.

I've got the same trouble when tried to use USB-LAN dongle. Now my RT-N66U got 5 LAN ports:)

MiCk 11-22-2013 12:35 PM

Thanks guys for support.

So I wrote in services-start:

[QUOTE]modprobe -r -v option.ko
insmod usbserial
insmod ftdi_sio[/QUOTE]

and oscam works :)

ryzhov_al what do you think, is it optimal or can I do this records better ?

ryzhov_al 11-22-2013 12:58 PM

I think it's optimal.


All times are GMT -4. The time now is 12:19 AM.

Powered by vBulletin® Version 3.7.3
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
© 2006-2014 Pudai LLC All Rights Reserved.